[Experimental] This combines the parameters so that they can be fed as multiple delay distributions to epinow() or estimate_infections().

Note that distributions that already are combinations of other distributions cannot be combined with other combinations of distributions.

# S3 method for class 'dist_spec'
c(...)

Arguments

...

The delay distributions to combine

Value

Combined delay distributions (with class <dist_spec>)

Examples

# A fixed lognormal distribution with mean 5 and sd 1.
dist1 <- LogNormal(
  meanlog = 1.6, sdlog = 1, max = 20
)
dist1 + dist1
#> Composite distribution:
#> - lognormal distribution (max: 20):
#>   meanlog:
#>     1.6
#>   sdlog:
#>     1
#> - lognormal distribution (max: 20):
#>   meanlog:
#>     1.6
#>   sdlog:
#>     1

# An uncertain gamma distribution with mean 3 and sd 2
dist2 <- Gamma(
  mean = Normal(3, 0.5), sd = Normal(2, 0.5), max = 20
)
#> Warning: ! Uncertain gamma distribution specified in terms of parameters that are not
#>   the "natural" parameters of the distribution shape and rate.
#>  Converting using a crude and very approximate method that is likely to
#>   produce biased results.
#>  If possible it is preferable to specify the distribution directly in terms of
#>   the natural parameters.
c(dist1, dist2)
#> Composite distribution:
#> - lognormal distribution (max: 20):
#>   meanlog:
#>     1.6
#>   sdlog:
#>     1
#> - gamma distribution (max: 20):
#>   shape:
#>     - normal distribution:
#>       mean:
#>         2.2
#>       sd:
#>         0.48
#>   rate:
#>     - normal distribution:
#>       mean:
#>         0.75
#>       sd:
#>         0.28