All functions

LogNormal() Gamma() Normal() Fixed() NonParametric()

Probability distributions

bound_dist()

Define bounds of a <dist_spec>

c(<dist_spec>)

Combines multiple delay distributions for further processing

collapse(<dist_spec>)

Collapse nonparametric distributions in a <dist_spec>

convert_to_logmean()

Convert mean and sd to log mean for a log normal distribution

convert_to_logsd()

Convert mean and sd to log standard deviation for a log normal distribution

discretise(<dist_spec>) discretize()

Discretise a <dist_spec>

fix_parameters(<dist_spec>)

Fix the parameters of a <dist_spec>

get_distribution()

Get the distribution of a <dist_spec>

get_parameters()

Get parameters of a parametric distribution

get_pmf()

Get the probability mass function of a nonparametric distribution

is_constrained(<dist_spec>)

Check if a <dist_spec> is constrained, i.e. has a finite maximum or nonzero CDF cutoff.

max(<dist_spec>)

Returns the maximum of one or more delay distribution

mean(<dist_spec>)

Returns the mean of one or more delay distribution

new_dist_spec()

Internal function for generating a dist_spec given parameters and a distribution.

plot(<dist_spec>)

Plot PMF and CDF for a dist_spec object

`+`(<dist_spec>)

Creates a delay distribution as the sum of two other delay distributions.

print(<dist_spec>)

Prints the parameters of one or more delay distributions