[Experimental]

# S3 method for class 'dist_spec'
is_constrained(x, ...)

Arguments

x

A <dist_spec>

...

ignored

Value

Logical; TRUE if x is constrained

Examples

# A fixed gamma distribution with mean 5 and sd 1.
dist1 <- Gamma(mean = 5, sd = 1, max = 20)

# An uncertain lognormal distribution with mean 3 and sd 2
dist2 <- LogNormal(mean = Normal(3, 0.5), sd = Normal(2, 0.5), max = 20)
#> Warning: ! Uncertain lognormal distribution specified in terms of parameters that are
#>   not the "natural" parameters of the distribution meanlog and sdlog.
#>  Converting using a crude and very approximate method that is likely to
#>   produce biased results.
#>  If possible it is preferable to specify the distribution directly in terms of
#>   the natural parameters.

# both distributions are constrained and therefore so is the sum
is_constrained(dist1 + dist2)
#> [1] TRUE