[Experimental] This works out the mean of all the (parametric / nonparametric) delay distributions combined in the passed <dist_spec>.

# S3 method for class 'dist_spec'
mean(x, ..., ignore_uncertainty = FALSE)

Arguments

x

The <dist_spec> to use

...

Not used

ignore_uncertainty

Logical; whether to ignore any uncertainty in parameters. If set to FALSE (the default) then the mean of any uncertain parameters will be returned as NA.

Examples

# A fixed lognormal distribution with mean 5 and sd 1.
dist1 <- LogNormal(mean = 5, sd = 1, max = 20)
mean(dist1)
#> [1] 5

# An uncertain gamma distribution with mean 3 and sd 2
dist2 <- Gamma(
 mean = Normal(3, 0.5), sd = Normal(2, 0.5), max = 20
)
#> Warning: ! Uncertain gamma distribution specified in terms of parameters that are not
#>   the "natural" parameters of the distribution shape and rate.
#>  Converting using a crude and very approximate method that is likely to
#>   produce biased results.
#>  If possible it is preferable to specify the distribution directly in terms of
#>   the natural parameters.
mean(dist2)
#> [1] NA

# The mean of the sum of two distributions
mean(dist1 + dist2)
#> [1]  5 NA